Search The ForumSearch   RegisterRegister  LoginLogin

AfterLogic Aurora

 AfterLogic Forum : AfterLogic Aurora
Subject Topic: Add module ldap-auth Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
freeman
Newbie
Newbie
Avatar

Joined: 11 September 2023
Location: Germany
Online Status: Offline
Posts: 2
Posted: 11 September 2023 at 12:44am | IP Logged Quote freeman

Hey there,

i'm testing out the aurora groupware features and i need user auth via ldap.
I've found the following module: https://github.com/afterlogic/aurora-module-ldap-auth

Which seems to be created by afterlogic: https://afterlogic.com/composer/#afterlogic/aurora-module-ldap-auth

So i've started to follow the instructions at: https://afterlogic.com/docs/aurora/installation/adding-modules to make things ready.

When i start to install the module via: php composer.phar update afterlogic/aurora-module-ldap-auth --with-all-dependencies
i'm running against the problem that the current version of ldap-auth module is version 0.9.0 while 0.10.0 is expected from root composer.json.

How and where to change the expected version? I'm running in many dependencie errors when i try to change version numbers in composer.json

I'm running Aurora 9.7.3.build10-build-o3 from debian/nginx installation.

Tips are welcome :)
Back to Top View freeman's Profile Search for other posts by freeman
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 6066
Posted: 11 September 2023 at 12:52am | IP Logged Quote Igor

Hello,

I'm afraid that module is outdated and hasn't been tested for compatibility with the latest version of the product. We're going to refactor it and ensure it's compatible, but there's no ETA for that. Thank you for understanding.

Since the module only contains server-side code, you can try installing the module manually by placing its code under modules/LdapAuth directory, you'll also need to copy config.json file to data/settings/modules/LdapAuth.config.json and configure it further. I must warn you, however, that Aurora codebase and API undergone significant changes this year so most likely, the module isn't going to work as expected.

--
Regards,
Igor, Afterlogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
freeman
Newbie
Newbie
Avatar

Joined: 11 September 2023
Location: Germany
Online Status: Offline
Posts: 2
Posted: 11 September 2023 at 2:21am | IP Logged Quote freeman

Hello Igor,

thanks for your fast reply!

I'm going to take a look if i get it to work but it seems like waiting for your refactoring is the way to go.


Thanks again.
Back to Top View freeman's Profile Search for other posts by freeman
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump

Powered by Web Wiz Forums version 7.9
Copyright ©2001-2004 Web Wiz Guide