Search The ForumSearch   RegisterRegister  LoginLogin

AfterLogic WebMail Lite

 AfterLogic Forum : AfterLogic WebMail Lite
Subject Topic: Creating tables fails Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
dwasifark
Newbie
Newbie
Avatar

Joined: 12 July 2023
Location: United States
Online Status: Offline
Posts: 3
Posted: 12 July 2023 at 8:51am | IP Logged Quote dwasifark

This is a new clean installation of WebMail Lite. I can log on to the admin page, and the MariaDB database exists, but the Creating Tables step fails. Only two tables are created:

Code:
MariaDB [afterlogic]> show tables;
+----------------------+
| Tables_in_afterlogic |
+----------------------+
| au_core_users        |
| au_migrations        |
+----------------------+
2 rows in set (0.000 sec)

Both tables are empty, but getting this far establishes that this is not a database connection problem. MariaDB logs do not show any attempts to create any other tables.

All versions are sufficient as far as I can tell. MariaDB is at version 10.11.3, PHP is at version 8.27, and client API version in the PHP summary page is mysqlnd 8.2.7, in both the mysqli section and the pdo_mysql sections.

Any suggestions? Thanks.
Back to Top View dwasifark's Profile Search for other posts by dwasifark
 
dwasifark
Newbie
Newbie
Avatar

Joined: 12 July 2023
Location: United States
Online Status: Offline
Posts: 3
Posted: 12 July 2023 at 10:29am | IP Logged Quote dwasifark

More information. Here is the mysql log from an attempt to create tables:

Code:

/usr/sbin/mariadbd, Version: 10.11.3-MariaDB-1 (Debian 12). started with:
Tcp port: 3306  Unix socket: /run/mysqld/mysqld.sock
Time              Id Command     Argument
230712 12:18:42      21180 Connect     root@localhost on  using TCP/IP
           21180 Connect     Access denied for user 'root'@'localhost' (using password: NO)
           21181 Connect     afterlogic@localhost on afterlogic using TCP/IP
           21181 Query     use `afterlogic`
           21181 Prepare     set names 'utf8' collate 'utf8_general_ci'
           21181 Execute     set names 'utf8' collate 'utf8_general_ci'
           21181 Close stmt     
           21181 Quit     
230712 12:18:54      21184 Connect     root@localhost on  using TCP/IP
           21184 Connect     Access denied for user 'root'@'localhost' (using password: NO)
           21185 Connect     afterlogic@localhost on afterlogic using TCP/IP
           21185 Query     use `afterlogic`
           21185 Prepare     set names 'utf8' collate 'utf8_general_ci'
           21185 Execute     set names 'utf8' collate 'utf8_general_ci'
           21185 Close stmt     
           21185 Quit     
230712 12:18:57      21186 Connect     afterlogic@localhost on afterlogic using TCP/IP
           21186 Query     use `afterlogic`
           21186 Prepare     set names 'utf8' collate 'utf8_general_ci'
           21186 Execute     set names 'utf8' collate 'utf8_general_ci'
           21186 Close stmt     
           21187 Connect     afterlogic@localhost on afterlogic using TCP/IP
           21187 Query     use `afterlogic`
           21187 Prepare     set names 'utf8' collate 'utf8_general_ci'
           21187 Execute     set names 'utf8' collate 'utf8_general_ci'
           21187 Close stmt     
           21187 Quit     
           21186 Quit     
230712 12:19:01      21188 Connect     afterlogic@localhost on afterlogic using TCP/IP
           21188 Query     use `afterlogic`
           21188 Prepare     set names 'utf8' collate 'utf8_general_ci'
           21188 Execute     set names 'utf8' collate 'utf8_general_ci'
           21188 Close stmt     
           21189 Connect     afterlogic@localhost on afterlogic using TCP/IP
           21189 Query     use `afterlogic`
           21189 Prepare     set names 'utf8' collate 'utf8_general_ci'
           21189 Execute     set names 'utf8' collate 'utf8_general_ci'
           21189 Close stmt     
           21189 Prepare     select * from information_schema.tables where table_schema = ? and table_name = ? and table_type = 'BASE TABLE'
           21189 Execute     select * from information_schema.tables where table_schema = 'afterlogic' and table_name = 'au_migrations' and table_type = 'BASE TABLE'
           21189 Close stmt     
           21189 Prepare     select `migration` from `au_migrations` order by `batch` asc, `migration` asc
           21189 Execute     select `migration` from `au_migrations` order by `batch` asc, `migration` asc
           21189 Close stmt     
           21189 Prepare     select max(`batch`) as aggregate from `au_migrations`
           21189 Execute     select max(`batch`) as aggregate from `au_migrations`
           21189 Close stmt     
           21189 Prepare     create table `au_core_users` (`Id` int unsigned not null auto_increment primary key, `UUID` varchar(255) not null, `Name` varchar(255) not null default '', `PublicId` varchar(255) not null, `IdTenant` int not null default '0', `IsDisabled` tinyint(1) not null default '0', `IdSubscription` int not null default '0', `Role` int not null default '2', `DateCreated` datetime null, `LastLogin` datetime null, `LastLoginNow` varchar(255) not null default '', `LoginsCount` int not null default '0', `Language` varchar(255) not null default '', `TimeFormat` int null default '1', `DateFormat` varchar(255) not null default '', `Question1` varchar(255) not null default '', `Question2` varchar(255) not null default '', `Answer1` varchar(255) not null default '', `Answer2` varchar(255) not null default '', `SipEnable` tinyint(1) not null default '1', `SipImpi` varchar(255) not null default '', `SipPassword` varchar(255) not null default '', `DesktopNotifications` tinyint(1) not null default '0', `Capa` varchar(255) not null default '', `CustomFields` varchar(255) not null default '', `FilesEnable` tinyint(1) not null default '1', `EmailNotification` varchar(255) not null default '', `PasswordResetHash` varchar(255) not null default '', `WriteSeparateLog` tinyint(1) not null default '0', `TokensValidFromTimestamp` int not null default '0', `DefaultTimeZone` varchar(255) not null default '', `Properties` json null, `CreatedAt` timestamp null, `UpdatedAt` timestamp null) default character set utf8 collate 'utf8_general_ci'
           21189 Execute     create table `au_core_users` (`Id` int unsigned not null auto_increment primary key, `UUID` varchar(255) not null, `Name` varchar(255) not null default '', `PublicId` varchar(255) not null, `IdTenant` int not null default '0', `IsDisabled` tinyint(1) not null default '0', `IdSubscription` int not null default '0', `Role` int not null default '2', `DateCreated` datetime null, `LastLogin` datetime null, `LastLoginNow` varchar(255) not null default '', `LoginsCount` int not null default '0', `Language` varchar(255) not null default '', `TimeFormat` int null default '1', `DateFormat` varchar(255) not null default '', `Question1` varchar(255) not null default '', `Question2` varchar(255) not null default '', `Answer1` varchar(255) not null default '', `Answer2` varchar(255) not null default '', `SipEnable` tinyint(1) not null default '1', `SipImpi` varchar(255) not null default '', `SipPassword` varchar(255) not null default '', `DesktopNotifications` tinyint(1) not null default '0', `Capa` varchar(255) not null default '', `CustomFields` varchar(255) not null default '', `FilesEnable` tinyint(1) not null default '1', `EmailNotification` varchar(255) not null default '', `PasswordResetHash` varchar(255) not null default '', `WriteSeparateLog` tinyint(1) not null default '0', `TokensValidFromTimestamp` int not null default '0', `DefaultTimeZone` varchar(255) not null default '', `Properties` json null, `CreatedAt` timestamp null, `UpdatedAt` timestamp null) default character set utf8 collate 'utf8_general_ci'
           21189 Close stmt     
           21189 Quit     
           21188 Quit     
230712 12:19:09      21177 Query     SET GLOBAL general_log = 'OFF'


You can see me testing access a couple of times there before trying the table create step. It also appears to be trying to connect with root, even though root is not defined as the user. Then it finally gets around to creating two tables, and quits, and that's it.
Back to Top View dwasifark's Profile Search for other posts by dwasifark
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 6028
Posted: 13 July 2023 at 12:04am | IP Logged Quote Igor

I'd recommend to enable logging in adminpanel of WebMail and see if you get any errors there. Detailed information on this can be found at:

Debug logging as main troubleshooting measure

Also, it may be worth a shot to check webserver/PHP error logs as well, just in case there might be some errors there as well.

--
Regards,
Igor, Afterlogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
dwasifark
Newbie
Newbie
Avatar

Joined: 12 July 2023
Location: United States
Online Status: Offline
Posts: 3
Posted: 14 July 2023 at 7:29pm | IP Logged Quote dwasifark

Thanks for the suggestion on logging. Error log revealed problems with ALTER and INDEX permissions, which had not been granted.

I got to the point of having everything configured and was able to successfully log in with a user account, and everything looked good until I logged out, at which point the page started an unbreakable refresh loop that persisted through both an nginx service restart and moving to another browser. (It's actually quite remarkable to have an error condition follow you to a new session on another browser.) I wiped the installation and started over, at which point it refused to connect to IMAP at all, with the exact same settings as before.

I'm giving up. I have Roundcube and Rainloop working fine on this server. I just wanted to evaluate Afterlogic, but it's becoming more trouble than it's worth.

Back to Top View dwasifark's Profile Search for other posts by dwasifark
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump

Powered by Web Wiz Forums version 7.9
Copyright ©2001-2004 Web Wiz Guide