Search The ForumSearch   RegisterRegister  LoginLogin

AfterLogic Aurora Files

 AfterLogic Forum : AfterLogic Aurora Files
Subject Topic: Using sendmail Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
bnoeafk
Newbie
Newbie
Avatar

Joined: 23 February 2022
Location: United States
Online Status: Offline
Posts: 9
Posted: 16 March 2022 at 6:41pm | IP Logged Quote bnoeafk

I'm struggling to get Aurora Files to work with sendmail. I'm sure my sendmail configuration is correct, as I can use :
sendmail -vf FromAddress@mydomain.com ToAddress@mydomain.com and everything works as expected.

The SMTP server that I connect to will only accept from authenticated users. This shouldn't be an issue.

I'm using the online support article to run through the process and nothing is getting sent. I'm pretty sure I've whittled down the issue. On that page, it states
Quote:
Open YOUR_INSTALLATION_ROOT/data/settings/modules/InvitationLinkWebclient.config.json in your favorite text editor.


Well, that file didn't exist on my installation, however YOUR_INSTALLATION_ROOT/data/settings/modules/InvitationLinkWebclient/config.json does exist. Therefore, (1) Can I get confirmation on the correct file to edit?

The rest may be totally dependent on (1) but I've updated both files and am still getting an error as my server attempts to send to the upstream SMTP server and I'm 100% sure it's because it's sending as web-data and not the configured NotificationEmail value. As I watch /var/log/mail.log on my server, I see that when I attempt to send the update link to a user, it's still connecting as web-data and my upstream SMTP server is expecting it from FromAddress@mydomain.com (2) Are there any additional tests that I can run to validate my thoughts?

If it helps, this is my ./modules/InvitationWebclient/config.json


{
        "Disabled": [
               false,
               "bool"
        ],
    "RegisterModuleName": [
               "StandardRegisterFormWebclient",
               "string"
        ],
        "LoginModuleName": [
               "StandardLoginFormWebclient",
               "string"
        ],
        "EnableSendInvitationLinkViaMail": [
               true,
               "bool"
        ],
        "NotificationType": [
               "smtp",
               "string"
        ],
        "NotificationEmail": [
               "FROMADDRESS@MYDOMAIN.COM",
               "string"
        ],
        "NotificationHost": [
               "SMTPSERVER.MYDOMAIN.COM",
               "string"
        ],
        "NotificationPort": [
               "587",
               "string"
        ],
        "NotificationUseAuth": [
               true,
               "bool"
        ],
        "NotificationLogin": [
               "SUPERSECUREUSERNAME",
               "string"
        ],
        "NotificationPassword": [
               "SUPERSECUREPASSWORD",
               "string"
        ],
        "SMTPSecure": [
               "",
               "string"
        ]
}
(I wasn't sure if I needed anything in SMTPSecure so have continued to leave it blank)

any thoughts?!
Back to Top View bnoeafk's Profile Search for other posts by bnoeafk
 
bnoeafk
Newbie
Newbie
Avatar

Joined: 23 February 2022
Location: United States
Online Status: Offline
Posts: 9
Posted: 16 March 2022 at 6:43pm | IP Logged Quote bnoeafk

Forgive me, an error on my account and I don't believe I can edit, only delete...


Well, that file didn't exist on my installation, however YOUR_INSTALLATION_ROOT/modules/InvitationLinkWebclient/config.json does exist. Therefore, (1) Can I get confirmation on the correct file to edit?


Please note: the modules folder is off of the INSTALLATION_ROOT, not under ./data/settings/modules/...
Back to Top View bnoeafk's Profile Search for other posts by bnoeafk
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5903
Posted: 16 March 2022 at 11:36pm | IP Logged Quote Igor

Hello,

Try pressing "Update configuration" button in "Database Settings" screen of adminpanel. Does the file show up under data/settings/modules directory?

--
Regards,
Igor, Afterlogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
bnoeafk
Newbie
Newbie
Avatar

Joined: 23 February 2022
Location: United States
Online Status: Offline
Posts: 9
Posted: 31 March 2022 at 9:27pm | IP Logged Quote bnoeafk

@Igor,
Yes - hitting that button certainly creates the required config files - I've reviewed this and all appears to be working just fine.

One thing that I would like to note / ask: I was under the impression that postfix was required to be functional on the server that Aurora Files is installed on, for the "smtp" (or sendmail) function to work. This doesn't appear to be true, as I've been checking the mail.log and my invites / emails aren't appearing to be going through postfix at all. So - can I safely assume that when configured to use SMTP, the invites connect directly out to the SMTP server in question, without having to relay through a local MTA?
Back to Top View bnoeafk's Profile Search for other posts by bnoeafk
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5903
Posted: 01 April 2022 at 12:02am | IP Logged Quote Igor

Well yes, when "NotificationType" is set to "smtp", that means Aurora Files will use the relay SMTP server you specify connection details for. So yes, local MTA isn't used unless you've set "NotificationHost" to point to it.

--
Regards,
Igor, Afterlogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump

Powered by Web Wiz Forums version 7.9
Copyright ©2001-2004 Web Wiz Guide