Search The ForumSearch   RegisterRegister  LoginLogin

AfterLogic WebMail Lite

 AfterLogic Forum : AfterLogic WebMail Lite
Subject Topic: Migration from V8 Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
lu_kaf
Newbie
Newbie


Joined: 15 November 2021
Online Status: Offline
Posts: 3
Posted: 15 November 2021 at 11:30pm | IP Logged Quote lu_kaf

Hello,
I am running my installation on WebmailLite 8.8.3-build-a3

I'd like to update to V9 and I am having a few issues.

Upgrade instructions say that we need first to migrate to the last version of V8, however I am not able to download the last version of V8 as we can only download the lastest version (V9.1.2).

I have tried to install V9 from the current build I haveand I am following the exact procedure, which means :
- deleting all of the content of my current webmail folder, except the data folder
- copying the new version to the old one, except the data folder
- executing the 2 lines of codes that are in the upgrading instructions

Once i have done that, i can't login to the webmail anymore (via any email account or the administrator account). It always says passwords are bad.

We are using post connection, so I have tried disabling it, but the same is occuring.

Any help would be appreciated !
Thanks.
Back to Top View lu_kaf's Profile Search for other posts by lu_kaf
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 6071
Posted: 15 November 2021 at 11:38pm | IP Logged Quote Igor

Hello,

The latest 8.* version is available for download at:

https://afterlogic.org/download/webmail-lite-php-8

However, you're already running the latest 8.* version, so that shouldn't be an issue.

In version 9, unlike previous v8, admin login is done through a separate /adminpanel/ URL - are you able to log in there?

Also, I'd recommend setting up a blank install of v9 on the same system, just to check if the issue is related to upgrading at all.

--
Regards,
Igor, Afterlogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 6071
Posted: 19 November 2021 at 5:09am | IP Logged Quote Igor

Are you able to access the old adminpanel? It's disabled in v9 by default, you can enable it by editing data/settings/modules/AdminAuth.config.json

Code:
{
    "Disabled": [
        false,
        "bool"
    ],
    "SuperadminWhitelistIp": [
        [],
        "array"
    ],
    "AllowLoginFromCoreModule": [
        true,
        "bool"
    ]
}


After that, you should be able to log into legacy admin interface. And if you still cannot access the new /adminpanel/ enable logging through the legacy admin interface and check the logs, maybe they shed some light onto what's going on.

--
Regards,
Igor, Afterlogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
lu_kaf
Newbie
Newbie


Joined: 15 November 2021
Online Status: Offline
Posts: 3
Posted: 19 November 2021 at 5:28am | IP Logged Quote lu_kaf

Hi Igor,

I've restarted everything from zero by deleting the migration tables.

I am now able to access the V9 adminpanel; but impossible to connect to my emails.
So i've tried to click on "test connexion to DB" and i am getting the following error :
Please make sure your PHP/MySQL environment meets the minimal system requirements
However, I think I am having the correct requirements : PHP 7.4 and 10.3.31 mariabd.

Any ideas ?
Back to Top View lu_kaf's Profile Search for other posts by lu_kaf
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 6071
Posted: 19 November 2021 at 5:40am | IP Logged Quote Igor

It appears System Requirements page was missing an important point, we've just added it there. For the database connection, the requirements in v9 are as follows:

Quote:
Database engine: MySQL 5.7.8 or newer / MariaDB 10.2.7 or newer, with mysqlnd driver


And looks like mysqlnd (MySQL native driver) is missing in your configuration, an old libmysql is probably used. The adminpanel, as well as the compatibility test, checks whether mysqli_fetch_all function is available in PHP configuration, that allows for determining if an up-to-date MySQL native driver is used.

Hope this helps.

--
Regards,
Igor, Afterlogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
lu_kaf
Newbie
Newbie


Joined: 15 November 2021
Online Status: Offline
Posts: 3
Posted: 19 November 2021 at 7:00am | IP Logged Quote lu_kaf

I've made the modifications and it now works super great

thanks a lot
Back to Top View lu_kaf's Profile Search for other posts by lu_kaf
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump

Powered by Web Wiz Forums version 7.9
Copyright ©2001-2004 Web Wiz Guide