Search The ForumSearch   RegisterRegister  LoginLogin

AfterLogic Aurora Files

 AfterLogic Forum : AfterLogic Aurora Files
Subject Topic: Can not create user Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
Kaloschke
Newbie
Newbie


Joined: 01 September 2021
Online Status: Offline
Posts: 7
Posted: 10 September 2021 at 9:38am | IP Logged Quote Kaloschke

Hi,
I get an error, when creating a user.
My log shows ...
Code:

[16:31:15.29][a140874e] @Time: 0.0087
[16:31:15.29][a140874e] @TimeApiInit: 0.0914
[16:31:15.29][a140874e] INFO[MEMORY]: Memory peak usage: 2MB
[16:31:15.29][a140874e] INFO[TIME]: Time delta: 1631291475.2994
[16:31:17.59][04ca3d68]  
[16:31:17.59][04ca3d68]  ===== API: LogsViewerWebclient::GetLogFilesData
[16:31:17.59][04ca3d68] @Time: 0.0079
[16:31:17.59][04ca3d68] @TimeApiInit: 0.1228
[16:31:17.59][04ca3d68] INFO[MEMORY]: Memory peak usage: 2MB
[16:31:17.59][04ca3d68] INFO[TIME]: Time delta: 1631291477.5986
[16:31:22.22][cd93644a]  
[16:31:22.22][cd93644a]  ===== API: Core::UpdateSettings
[16:31:22.22][cd93644a] @Time: 0.011
[16:31:22.22][cd93644a] @TimeApiInit: 0.1019
[16:31:22.22][cd93644a] INFO[MEMORY]: Memory peak usage: 2MB
[16:31:22.22][cd93644a] INFO[TIME]: Time delta: 1631291482.228
[16:31:22.76][b4475035]  
[16:31:22.76][b4475035]  ===== API: LogsViewerWebclient::GetLogFilesData
[16:31:22.76][b4475035] @Time: 0.0057
[16:31:22.76][b4475035] @TimeApiInit: 0.1257
[16:31:22.76][b4475035] INFO[MEMORY]: Memory peak usage: 2MB
[16:31:22.76][b4475035] INFO[TIME]: Time delta: 1631291482.765
[16:31:25.07][58f1c34b]  
[16:31:25.07][58f1c34b]  ===== API: Core::GetUsers
[16:31:25.10][58f1c34b] @Time: 0.032
[16:31:25.10][58f1c34b] @TimeApiInit: 0.0954
[16:31:25.10][58f1c34b] INFO[MEMORY]: Memory peak usage: 4MB
[16:31:25.10][58f1c34b] INFO[TIME]: Time delta: 1631291485.1035
[16:31:42.53][0b497c0b]  
[16:31:42.53][0b497c0b]  ===== API: Core::CreateUser
[16:31:42.55][0b497c0b] Exception: ApiException
[16:31:42.55][0b497c0b] @Time: 0.032
[16:31:42.55][0b497c0b] @TimeApiInit: 0.1072
[16:31:42.55][0b497c0b] INFO[MEMORY]: Memory peak usage: 4MB
[16:31:42.55][0b497c0b] INFO[TIME]: Time delta: 1631291502.5596
[16:31:52.82][75fb542b]  
[16:31:52.82][75fb542b]  ===== API: LogsViewerWebclient::GetLogFilesData
[16:31:52.82][75fb542b] @Time: 0.0059
[16:31:52.82][75fb542b] @TimeApiInit: 0.1046
[16:31:52.82][75fb542b] INFO[MEMORY]: Memory peak usage: 2MB
[16:31:52.82][75fb542b] INFO[TIME]: Time delta: 1631291512.8274
[16:31:52.83][307601d3]  
[16:31:52.83][307601d3]  ===== API: LogsViewerWebclient::GetUsersWithSeparateLog
[16:31:52.85][307601d3] @Time: 0.0239
[16:31:52.85][307601d3] @TimeApiInit: 0.1138
[16:31:52.85][307601d3] INFO[MEMORY]: Memory peak usage: 4MB
[16:31:52.85][307601d3] INFO[TIME]: Time delta: 1631291512.858
[16:31:54.77][267229e4]  
[16:31:54.77][267229e4]  ===== API: LogsViewerWebclient::GetLog
      
Back to Top View Kaloschke's Profile Search for other posts by Kaloschke
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5752
Posted: 12 September 2021 at 11:29pm | IP Logged Quote Igor

Quote:
[16:31:42.55][0b497c0b] Exception: ApiException


You need to enable complete stack trace in the logs, by setting LogStackTrace to true in data/settings/config.json configuration file. Note that it will result in getting sensitive information such as passwords in the logs, so you may need to replace those when posting the exception details.

--
Regards,
Igor, Afterlogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5752
Posted: 12 September 2021 at 11:31pm | IP Logged Quote Igor

Also, make sure your environment meets minimal system requirements, that can be checked using the compatibility test.

--
Regards,
Igor, Afterlogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
Kaloschke
Newbie
Newbie


Joined: 01 September 2021
Online Status: Offline
Posts: 7
Posted: 15 September 2021 at 5:39am | IP Logged Quote Kaloschke

It was a database error. Everything is working now.
Thank you very much
Back to Top View Kaloschke's Profile Search for other posts by Kaloschke
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump

Powered by Web Wiz Forums version 7.9
Copyright ©2001-2004 Web Wiz Guide