Search The ForumSearch   RegisterRegister  LoginLogin

AfterLogic WebMail Pro

 AfterLogic Forum : AfterLogic WebMail Pro
Subject Topic: The type exists in both App_Code & Wbste? Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
mangesh.barmate
Newbie
Newbie
Avatar

Joined: 18 May 2016
Location: India
Online Status: Offline
Posts: 20
Posted: 23 May 2016 at 5:10am | IP Logged Quote mangesh.barmate

Hi,
I am receiving below error while building a website-
Error:
The type ‘Log’ exists in both 1_App_code, version=0.0.0.0, Culture=neutral, PublicKeyToken=null’ and ‘WebMail, version5.0.0.0, Culture=neutral, PublicKeyToken=null’
For Line: Log.WriteLine(">>>IN>>", paramsToLog);

File Name: Processing.aspx.cs

Please suggest.

Thanks.
Back to Top View mangesh.barmate's Profile Search for other posts by mangesh.barmate
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5885
Posted: 23 May 2016 at 5:14am | IP Logged Quote Igor

Can you confirm the issue occurs with the unmodified version of WebMail Pro?

--
Regards,
Igor, AfterLogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
mangesh.barmate
Newbie
Newbie
Avatar

Joined: 18 May 2016
Location: India
Online Status: Offline
Posts: 20
Posted: 23 May 2016 at 5:22am | IP Logged Quote mangesh.barmate

Hi,

I have verified and found issue exists with Unmodified Version of WebMail Pro.

Please suggest.

Thanks.
Back to Top View mangesh.barmate's Profile Search for other posts by mangesh.barmate
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5885
Posted: 23 May 2016 at 5:23am | IP Logged Quote Igor

Is the error thrown when you run compile.bat file found in root WebMail folder?

--
Regards,
Igor, AfterLogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5885
Posted: 23 May 2016 at 5:26am | IP Logged Quote Igor

Also, does 1_App_code sound like anything from the website you build? I'm quite sure that one is not there in WebMail Pro.

--
Regards,
Igor, AfterLogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
mangesh.barmate
Newbie
Newbie
Avatar

Joined: 18 May 2016
Location: India
Online Status: Offline
Posts: 20
Posted: 23 May 2016 at 5:51am | IP Logged Quote mangesh.barmate

Hi,

No, I did not modify anything in it.
Can you tell me how this compile.bat run?

Thanks.
Back to Top View mangesh.barmate's Profile Search for other posts by mangesh.barmate
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5885
Posted: 23 May 2016 at 5:54am | IP Logged Quote Igor

It's a simple executable, double-click it in Explorer window or enter its name in command prompt.

--
Regards,
Igor, AfterLogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
mangesh.barmate
Newbie
Newbie
Avatar

Joined: 18 May 2016
Location: India
Online Status: Offline
Posts: 20
Posted: 23 May 2016 at 6:14am | IP Logged Quote mangesh.barmate

Hi,
I have run compiler.bat file from explorer. It gives me same build error.

Thanks.
Back to Top View mangesh.barmate's Profile Search for other posts by mangesh.barmate
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5885
Posted: 23 May 2016 at 6:17am | IP Logged Quote Igor

Based on the error message, looks like there's a conflict between WebMail Pro and your application code as that one has Log type there too. You'll probably need to rename that one, or move WebMail Pro out of your application root so that's a separate application.

--
Regards,
Igor, AfterLogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump

Powered by Web Wiz Forums version 7.9
Copyright ©2001-2004 Web Wiz Guide