Search The ForumSearch   RegisterRegister  LoginLogin

MailBee.NET POP3

 AfterLogic Forum : MailBee.NET POP3
Subject Topic: Access to delegate MAILBOX Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
Random
Newbie
Newbie
Avatar

Joined: 26 May 2011
Location: Italy
Online Status: Offline
Posts: 5
Posted: 26 May 2011 at 8:57am | IP Logged Quote Random

Hi, this is Mirko from Rome,

I wonder how I could get access to a mailbox as delegate user using MailBee.NET, over POP3 connection.

According to RFC1939 this is the right syntax to get access to resource_mb which access has been fully granted to user "delegated":

USER DOMAIN/delegated/resource_mb
PASS user_passwd

I'm not able to have the user string working with Exchange 2007... I tried:

- DOMAIN/delegated/resource_mb
- delegated/resource_db (having domain string defined)
- delegated@domain.local/resource_db

all of them working via telnet.

Related links:
http://msdn.microsoft.com/en-us/library/ee201471%28v=exchg.80%29.aspx
http://support.microsoft.com/kb/937359/en-us

What to do?

thanks in advance
Back to Top View Random's Profile Search for other posts by Random
 
Random
Newbie
Newbie
Avatar

Joined: 26 May 2011
Location: Italy
Online Status: Offline
Posts: 5
Posted: 26 May 2011 at 9:41am | IP Logged Quote Random

Sorry, the right RFC for syntax rules is 822.
Back to Top View Random's Profile Search for other posts by Random
 
Alex
AfterLogic Support
AfterLogic Support
Avatar

Joined: 19 November 2003
Online Status: Offline
Posts: 2206
Posted: 26 May 2011 at 9:50am | IP Logged Quote Alex

Which version of MailBee.NET.dll is being used? If not the latest, upgrade to the latest version.

If it does not work with the latest version, please show the log file contents. Log is always the first tool to start any trouble-shooting.

regards,
Alex
Back to Top View Alex's Profile Search for other posts by Alex
 
Random
Newbie
Newbie
Avatar

Joined: 26 May 2011
Location: Italy
Online Status: Offline
Posts: 5
Posted: 27 May 2011 at 1:47am | IP Logged Quote Random

Hi Alex,

thanks for your answer. We are currently using 6.9.2.293 version.

The error message:
          The server has rejected authentication data sent by the client. The server responded: -ERR Logon failure: unknown user name or bad password.. MailBee.Pop3Mail.MailBeePop3LoginBadCredentialsException: The server has rejected authentication data sent by the client. The server responded: -ERR Logon failure: unknown user name or bad password..    at a.g.a(SaslMethod A_0)    at a.g.a(SaslMethod A_0, String A_1, String A_2, String A_3, String A_4, String A_5)    at a.g.a(AuthenticationMethods A_0, AuthenticationMethods A_1, SaslMethod A_2, AuthenticationOptions A_3, String A_4, String A_5, String A_6, String A_7)    at a.ab.a(AuthenticationMethods A_0, AuthenticationMethods A_1, SaslMethod A_2, AuthenticationOptions A_3, String A_4, String A_5, String A_6, String A_7)    at a.ab.b()    at a.h.b.e(Boolean A_0)    at a.h.b.b()    at a.ao.a0()    at a.v.a(Boolean A_0, String A_1, String A_2, String A_3, String A_4, AuthenticationMethods A_5, AuthenticationOptions A_6, SaslMethod A_7)    at MailBee.Pop3Mail.Pop3.Login(String targetName, String domain, String accountName, String password, AuthenticationMethods authMethods, AuthenticationOptions authOptions, SaslMethod authUserDefined)    at FormMain.buttonLastMessage_Click(Object sender, EventArgs e) in C:\Users\a.bonomo\Desktop\MailBeeDemo\POP3 Demo 1\FormMain.vb:line 441

Thanks and regards
Back to Top View Random's Profile Search for other posts by Random
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 6062
Posted: 27 May 2011 at 6:15am | IP Logged Quote Igor

Exception message itself is not enough, log file is required. Thank you.

--
Regards,
Igor, AfterLogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
Random
Newbie
Newbie
Avatar

Joined: 26 May 2011
Location: Italy
Online Status: Offline
Posts: 5
Posted: 17 June 2011 at 2:02am | IP Logged Quote Random

Hi,

this is the log:

Code:
[10:47:44.36] [INFO] Will resolve host "mail.mydomain.net".
[10:47:44.38] [INFO] Host "mail.mydomain.net" resolved to IP address(es) 192.168.1.8.
[10:47:44.38] [INFO] Will connect to host "mail.mydomain.net" on port 110.
[10:47:44.38] [INFO] Socket connected to IP address 192.168.1.8 on port 110.
[10:47:44.39] [RECV] +OK The Microsoft Exchange POP3 service is ready.\r\n
[10:47:44.39] [INFO] Connected to mail service at host "mail.mydomain.net" on port 110 and ready.
[10:47:54.63] [INFO] Get the list of POP3 capabilities via CAPA command.
[10:47:54.63] [SEND] CAPA\r\n
[10:47:54.63] [RECV] +OK\r\nTOP\r\nUIDL\r\nSASL NTLM GSSAPI PLAIN\r\nUSER\r\nSTLS\r\n.\r\n
[10:47:54.63] [INFO] Will login as "domain\account\mailbox".
[10:47:54.63] [INFO] Will try SASL NTLM authentication method.
[10:47:54.65] [SEND] AUTH NTLM\r\n
[10:47:54.66] [RECV] + \r\n
[10:48:09.68] [SEND] TlRMTVNTUAABAAAAl4II4gAAAAAAAAAAAAAAAAAAAAAGAbEdAAAADw==\r\n
[10:48:09.68] [RECV] +  TlRMTVNTUAACAAAADAAMADgAAAAVgoniTsLF0G2p5GkAAAAAAAAAALQAtABEAAAABgByFwAAAA9SAEEATgBEAE8ATQACAAwAUgBBAE4ARABPAE0AAQAOAFIATgBEAFMAVgBSADEABAAiAFIAYQBuAGQAbwBtAFIAZQBzAGUAYQByAGMAaAAuAGkAdAADADIAUgBOAEQA UwBWAFIAMQAuAFIAYQBuAGQAbwBtAFIAZQBzAGUAYQByAGMAaAAuAGkAdAAFACIAUgBhAG4AZABvAG0AUgBlAHMAZQBhAHIAYwBoAC4AaQB0AAcACAC6HSRIyyzMAQAAAAA=\r\n
[10:48:09.68] [SEND]  TlRMTVNTUAADAAAAGAAYAJQAAAA8ATwBrAAAAAwADABYAAAAIgAiAGQAAAAOAA4AhgAAABAAEADoAQAAFYKI4gYBsR0AAAAPzJ4Prgiojs78lyBK8Q6m5HIAYQBuAGQAbwBtAHIAYQBuAGQAbwBtAHMAZQByAHYAaQBjAGUAXABjAHIAbQBEAEUAVgBTAFYAUgAxAAAA AAAAAAAAAAAAAAAAAAAAAAAAAAAAABXRsXsYxBFepzFIDhGq17cBAQAAAAAAALodJEjLLMwBY+3ZXrmB1G8AAAAAAgAMAFIAQQBOAEQATwBNAAEADgBSAE4ARABTAFYAUgAxAAQAIgBSAGEAbgBkAG8AbQBSAGUAcwBlAGEAcgBjAGgALgBpAHQAAwAyAFIATgBEAFMA VgBSADEALgBSAGEAbgBkAG8AbQBSAGUAcwBlAGEAcgBjAGgALgBpAHQABQAiAFIAYQBuAGQAbwBtAFIAZQBzAGUAYQByAGMAaAAuAGkAdAAHAAgAuh0kSMsszAEGAAQAAgAAAAgAMAAwAAAAAAAAAAAAAAAAIAAANMXBeLI99YyfsoRDQGSV2XA1wHwUnnlRQ8oX2dIT fswKABAAAAAAAAAAAAAAAAAAAAAAAAkAAAAAAAAAAAAAAAAAAABSUzGadYfpQFf+NzPL8zyy\r\n
[10:48:09.68] [RECV] -ERR Logon failure: unknown user name or bad password.\r\n
[10:48:09.81] [INFO] Will try SASL PLAIN authentication method.
[10:48:09.81] [SEND] AUTH PLAIN\r\n
[10:48:09.81] [RECV] + \r\n
[10:48:09.81] [SEND] ********\r\n
[10:48:09.81] [RECV] -ERR Logon failure: unknown user name or bad password.\r\n
[10:48:09.90] [INFO] Error: The server has rejected authentication data sent by the client. The server responded: -ERR Logon failure: unknown user name or bad password..
[10:48:22.42] [SEND] QUIT\r\n
[10:48:22.42] [RECV] +OK Microsoft Exchange Server 2007 POP3 server signing off.\r\n
[10:48:22.42] [INFO] Will disconnect from host "mail.mydomain.net".
[10:48:22.42] [INFO] Disconnected from host "mail.mydomain.net".


This is what I get via telnet:

Code:
telnet mail.mydomain.net 110
+OK The Microsoft Exchange POP3 service is ready.
user domain\account\mailbox
+OK
pass ************
+OK User successfully logged on.
Back to Top View Random's Profile Search for other posts by Random
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 6062
Posted: 17 June 2011 at 2:52am | IP Logged Quote Igor

Does it work for you if you supply AuthenticationMethods.Regular for Login method?

This authentication method, however, is non-secure and thus not recommended for production use. If you'd like us to help you on this issue, please provide us with a test account, you can send the details via HelpDesk.
Back to Top View Igor's Profile Search for other posts by Igor
 
Random
Newbie
Newbie
Avatar

Joined: 26 May 2011
Location: Italy
Online Status: Offline
Posts: 5
Posted: 17 June 2011 at 3:22am | IP Logged Quote Random

Igor wrote:
Does it work for you if you supply AuthenticationMethods.Regular for Login method?

This authentication method, however, is non-secure and thus not recommended for production use. If you'd like us to help you on this issue, please provide us with a test account, you can send the details via HelpDesk.


Great, it works!
Does the "auto" method stuck with Exchange SASL? Could it be a certificate issue?
Back to Top View Random's Profile Search for other posts by Random
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 6062
Posted: 17 June 2011 at 3:26am | IP Logged Quote Igor

With "auto" approach, as you can see from the log file, secure method is used first, and only then - less secure one (plain). Since it gets logon failure, MailBee doesn't try any other methods.

--
Regards,
Igor, AfterLogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
Alex
AfterLogic Support
AfterLogic Support
Avatar

Joined: 19 November 2003
Online Status: Offline
Posts: 2206
Posted: 17 June 2011 at 8:28am | IP Logged Quote Alex

The problem with NTLM is that is does not support aliases. While with regular authentication you can specify all the fields in the username (the actual username, domain, and alias), NTLM does not allow that, only username and domain are accepted (domain\username).

Regards,
Alex
Back to Top View Alex's Profile Search for other posts by Alex
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump

Powered by Web Wiz Forums version 7.9
Copyright ©2001-2004 Web Wiz Guide