Search The ForumSearch   RegisterRegister  LoginLogin

MailBee.NET Security

 AfterLogic Forum : MailBee.NET Security
Subject Topic: SslStartupMode.Manual not working Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
emacarie
Newbie
Newbie


Joined: 02 April 2010
Online Status: Offline
Posts: 4
Posted: 02 April 2010 at 11:52am | IP Logged Quote emacarie

The SslStartupMode is not working with a
Mailbee.Imap or Mailbee.Pop3 connection in
certain situations.
I am trying to connect to a server on port 995
using Pop3 Without SSL. Even though I
set the SslMode to Manual and I never call
StartTls, the Mailbee libraries still try to
connect using SSL . According to the
documentation when the SslMode is Manual the
connection will not use SSL unless I call
StartTls().
I use the below code to try to make a Pop3
connection to a server called "server" and port
995. I do not want to use SSL however.

_pop3Conn = new Pop3();
_pop3Conn.SslMode =
MailBee.Security.SslStartupMode.Manual;
_pop3Conn.Connect("server", 995);


After the connection is made the value of
_pop3Conn.IsSslConnection
is true.
I need Mailbee to make the above connection
without using ssl. Is this possible ?
Thank you.
Back to Top View emacarie's Profile Search for other posts by emacarie
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5931
Posted: 02 April 2010 at 12:43pm | IP Logged Quote Igor

Try setting this option to false.

Does it help?

--
Regards,
Igor, AfterLogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
emacarie
Newbie
Newbie


Joined: 02 April 2010
Online Status: Offline
Posts: 4
Posted: 02 April 2010 at 1:47pm | IP Logged Quote emacarie

Thank you ! That was exactly the setting I
needed. Much appreciated.
Back to Top View emacarie's Profile Search for other posts by emacarie
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump

Powered by Web Wiz Forums version 7.9
Copyright ©2001-2004 Web Wiz Guide