Search The ForumSearch   RegisterRegister  LoginLogin

MailBee.NET IMAP

 AfterLogic Forum : MailBee.NET IMAP
Subject Topic: System.ArgumentOutOfRangeException f Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
dbraaten
Newbie
Newbie


Joined: 23 December 2008
Online Status: Offline
Posts: 2
Posted: 23 December 2008 at 10:09am | IP Logged Quote dbraaten

Hi,

When checking the Size property on a message retrieved via IMAP we sometimes get this exception.

System.ArgumentOutOfRangeException: Index and length must refer to a location within the string.
Parameter name: length
   at System.String.InternalSubStringWithChecks(
               Int32 startIndex, Int32 length, Boolean fAlwaysCopy)
   at o.a(
               String A_0, Int32 A_1, String A_2)
   at dj.a(
               Byte[] A_0, MailTransferEncoding A_1)
   at MailBee.Mime.MimePart.i ()
   at MailBee.Mime.MimePart.i ()
   at MailBee.Mime.MailMessage.g ()
   at MailBee.Mime.MailMessage.get_Size ()

This is in version 3.1.1.90 of MailBee.NET.dll.

D
Back to Top View dbraaten's Profile Search for other posts by dbraaten
 
Alex
AfterLogic Support
AfterLogic Support
Avatar

Joined: 19 November 2003
Online Status: Offline
Posts: 2182
Posted: 23 December 2008 at 10:23am | IP Logged Quote Alex

Does the issue persist with the latest version from http://www.afterlogic.com/updates/mailbee_net_1.zip?

You can read the update instructions in MailBee.NET Objects FAQ

If the issue persists, does it also persist when you load that message from file instead of IMAP server? I.e. you can get it from IMAP server, save it into .EML file with SaveMessage method. Then, you can load it with LoadMessage and examine Size property.

Regards,
Alex
Back to Top View Alex's Profile Search for other posts by Alex
 
dbraaten
Newbie
Newbie


Joined: 23 December 2008
Online Status: Offline
Posts: 2
Posted: 23 December 2008 at 4:23pm | IP Logged Quote dbraaten

Hi,

The problem message had some lines in the header ending with \r\r\n I am assuming this is the cause of the problem. I have been unable to recreate a message with the funky line terminator to recreate the issue. The original message that caused the problem was deleted.

D
Back to Top View dbraaten's Profile Search for other posts by dbraaten
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5948
Posted: 24 December 2008 at 7:12am | IP Logged Quote Igor

If you encounter such issue again, please send us the message which causes it using Support Request form.

Regards,
Igor
Back to Top View Igor's Profile Search for other posts by Igor
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump

Powered by Web Wiz Forums version 7.9
Copyright ©2001-2004 Web Wiz Guide