Search The ForumSearch   RegisterRegister  LoginLogin

MailBee SMTP

 AfterLogic Forum : MailBee SMTP
Subject Topic: Timeout when retrieving message Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
Luca
Guest Group
Guest Group


Joined: 10 November 2003
Online Status: Online
Posts: 262
Posted: 05 July 2005 at 1:24pm | IP Logged Quote Luca

Hi Alex,

I installed my app on two PCs and I am experimenting a problem when downloading messages on one of the two

(the other one works well); I have no clue on what is going wrong. No need to say the code is identical on both machines.

Both machines are on the same local network and are sharing the same connection. The mailbox contains two

messages: they are download correctly by PC #1, but PC #2 hangs when downloading the first message, until it

times out.

At first I thought the issue may be caused by some settings in the firewall, if any, but after analyzing the

logs I see the strange thing is that headers are retrieved with no problem (I suppose if it was a "firewall

thing" no connection at all could occur).

These are the logs:

PC #1 (works well):

19:13:10 [MailBee POP3 v. 5.3.0.47. Registered version]
19:13:10 [Connecting to server xxx at port 110]
19:13:10 [Using regular POP3 authentication]
19:13:10 [Sending UserName]
19:13:10 [Sending Password]
19:13:10 [Connected to the server, getting stat]
19:13:10 [Got stat, 2 message(s) available. Total size is 3199 bytes]
19:13:10 [Getting list]
19:13:10 [Got list]
19:13:10 [Sending UIDL]
19:13:10 [UID List ready]
19:13:10 [UID Array ready]
19:13:10 [Sending retr/top command: top 1 0\r\n]
19:13:10 [Message data received, decoding the message]
19:13:10 [The message is ready]
19:13:10 [Sending retr/top command: retr 1\r\n]
19:13:10 [Message data received, decoding the message]
19:13:10 [The message is ready]
19:13:11 [Sending retr/top command: top 2 0\r\n]
19:13:11 [Message data received, decoding the message]
19:13:11 [The message is ready]
19:13:11 [Sending retr/top command: retr 2\r\n]
19:13:11 [Message data received, decoding the message]
19:13:11 [The message is ready]
19:13:11 [Disconnecting from the server]
19:13:11 [Connection closed]


PC #2 (hangs; timeout after 1 min):

18:38:12 [MailBee POP3 v. 5.3.0.47. Registered version]
18:38:12 [Connecting to server xxx at port 110]
18:38:12 [Using regular POP3 authentication]
18:38:12 [Sending UserName]
18:38:12 [Sending Password]
18:38:12 [Connected to the server, getting stat]
18:38:13 [Got stat, 2 message(s) available. Total size is 3199 bytes]
18:38:13 [Getting list]
18:38:13 [Got list]
18:38:13 [Sending UIDL]
18:38:13 [UID List ready]
18:38:13 [UID Array ready]
18:38:13 [Sending retr/top command: top 1 0\r\n]
18:38:13 [Message data received, decoding the message]
18:38:13 [The message is ready]
18:38:13 [Sending retr/top command: retr 1\r\n]
18:39:13 [Connection closed due network error or timeout.]
18:39:13 [Error: message/headers retrieving failed]

What could be causing such a strange behaviour? Is there a way I can get more information about this network

error / timeout?

Thanks
Back to Top View Luca's Profile Search for other posts by Luca
 
Alex
AfterLogic Support
AfterLogic Support
Avatar

Joined: 19 November 2003
Online Status: Offline
Posts: 2182
Posted: 05 July 2005 at 1:56pm | IP Logged Quote Alex

Maybe there is some kind of advanced firewall installed. For example, it might scan all incoming traffic and block certain messages if they contain spam or virus.

Try to open telnet on PC#2:

telnet xxx 110[enter]
then type the following commands:
USER username[enter]
PASS password[enter]
STAT[enter]
LIST[enter]
UIDL[enter]
TOP 1 0[enter]
RETR 1[enter]

What happens?

Regards,
Alex
Back to Top View Alex's Profile Search for other posts by Alex
 
Luca
Guest Group
Guest Group


Joined: 10 November 2003
Online Status: Online
Posts: 262
Posted: 06 July 2005 at 6:22am | IP Logged Quote Luca

(sorry Alex, I realize I should have posted this thread in Mailbee.POP3 instaed of Mailbee.SMTP).

Telnet works: the message is retrieved with no problems.

I got a

RETR 1+OK 1589 octets follow.

and then the full source of the message (with no delay or timeout).

After that i quit with command

QUIT[enter]

and it works (which means that connection didn't go off when retrieving message).
Back to Top View Luca's Profile Search for other posts by Luca
 
Alex
AfterLogic Support
AfterLogic Support
Avatar

Joined: 19 November 2003
Online Status: Offline
Posts: 2182
Posted: 06 July 2005 at 8:40am | IP Logged Quote Alex

Could you please install debug version of MailBee.dll on PC#2 (you can get it at http://www.afterlogic.com/updates/mailbee_debug.zip, execute the code which hangs, and then send us to support@afterlogic.com the contents of C:\mailbee_debug.txt log file?

Regards,
Alex
Back to Top View Alex's Profile Search for other posts by Alex
 
Luca
Guest Group
Guest Group


Joined: 10 November 2003
Online Status: Online
Posts: 262
Posted: 06 July 2005 at 10:17am | IP Logged Quote Luca

File sent

Thank You
Back to Top View Luca's Profile Search for other posts by Luca
 
Alex
AfterLogic Support
AfterLogic Support
Avatar

Joined: 19 November 2003
Online Status: Offline
Posts: 2182
Posted: 06 July 2005 at 1:35pm | IP Logged Quote Alex

I updated http://www.afterlogic.com/updates/mailbee_debug.zip with newer version. Could you please execute your code again and send us new log? It will contain some new lines of data which might be helpful for us.

Also, what happens when you type all these commands in one moment:
USER username[enter]
PASS password[enter]
STAT[enter]
LIST[enter]
UIDL[enter]
TOP 1 0[enter]
RETR 1[enter]

I.e. you can save them all in a text file (with real CRLF instead of [Enter]) and then copy/paste them (including last CRLF) at once so that all the responses appeared as one chunk.
It might be possible that regular telnet works fine because you enter commands with large intervals but when they are sent quickly, the problem occurs.

Regards,
Alex
Back to Top View Alex's Profile Search for other posts by Alex
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump

Powered by Web Wiz Forums version 7.9
Copyright ©2001-2004 Web Wiz Guide